priPrinter: booklet cover on heavy weight paper - priPrinter

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

booklet cover on heavy weight paper

#1 User is offline   Sandor 

  • Newbie
  • Pip
  • Group: Senior Members
  • Posts: 3
  • Joined: 23-July 12

Posted 23 July 2012 - 01:19 AM

I need to print the first sheet of a booklet as single sided document and the rest of the sheets as double sided.
Obviously this first sheet is the booklet cover, and this sheet must be printed on heavy weight paper.
My printer can't print double sided documents on heavy weight paper, but this is not a problem because the cover sheet is usually not double sided.
I have found the way to print the first sheet on heavy weight paper and the rest as plain paper.
But PriPrinter wants to print the back side of the first sheet even if it is blank.
As you can read on the priPrinter help the "do not print empty pages" option remains unavailable in duplex mode. In duplex mode check box is disabled. In double sided mode it can mess pages in random order.
Now I need to find a way (if possible using scripting?) to skip/avoid printing the back side of the first sheet in booklet (duplex) mode.
Any hint? Regards
-26

#2 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 23 July 2012 - 07:50 AM

It should be easy, please try this script:

local doc=window.GetDocument();
if(doc && doc.numpages) // avoid call on empty document
{
	layout.tray="Manual Feed"; // tray for heavy paper
	layout.Print({dialog=false, from=0, to=0}); // print first side of the first page

	local N= layout.GetNumSheets();	
	if(N>2)
	{ 
	 layout.tray="Normal"; // regular tray
	 layout.Print({dialog=false, from=2, to=N-1});// print rest pages
	}
}


It selects tray for the first page and prints only one side of it. Next, script selects another tray and prints rest pages. Back side of the first page should be skipped.
You may comment any part (with // )if you want to print first or rest pages separately.
In case of something else please let me know - here of via email.
-5

#3 User is offline   Sandor 

  • Newbie
  • Pip
  • Group: Senior Members
  • Posts: 3
  • Joined: 23-July 12

Posted 23 July 2012 - 10:57 PM

Good idea, but not good enough. <_<
The script seems to work: the printer take the first sheet from manual feed tray and print on it as thick paper,
then prints the remaining pages taking the paper from normal tray, printing on them in duplex mode,
but the best result that I have had is that for every first sheet, I have to press the OK button on the printer that writes on its display that "the F / R printing is not available" because it comes to take the paper from manual feed tray as thick paper. :angry:
If I tell to printer to ignore paper type, it prints on the first sheet as plain paper (not properly fixing the toner) and it prints the back side (blank) with duplex.

My printer is an Epson AL-C4000... this it could be the problem ??? :(

I hope you can help to solve my issue,

but can I suggest (for next priprinter update) to allow to optionally set for each job the "standard", "booklet" or "poster mode,
and allow to set the printer driver options for each job too ???
-2

#4 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 24 July 2012 - 06:48 AM

I think it's a good starting point.
Just a quick question - Have you changed names for the trays in the script?

So, is the problem with the first page only? Right? Probably printer still prints it in the auto duplex mode. Please confirm.

Thank you.
-2

#5 User is offline   Sandor 

  • Newbie
  • Pip
  • Group: Senior Members
  • Posts: 3
  • Joined: 23-July 12

Posted 24 July 2012 - 09:22 PM

yes, I do... I have changed the names (layout.tray="Cassetto MF"; // tray for heavy paper and layout.tray="Cassetto inferiore 1"; // regular tray)

The confirmation request by the printer is only for the first sheet, the one taken from the manual feed tray
-2

#6 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 25 July 2012 - 07:08 AM

Thank you for confirmation.

In this case please disable duplex for this tray in priPrinter options.
In priPrinter click on the Gear icon. See image below.
Posted Image
Goto to Trays tab and double click on the ("Cassetto MF") tray for Heavy paper and check [X] No Duplex.
I hope it should solve the problem. If not, please get back to me.

Thank you,
A.
-1

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users