priPrinter: PDF creating Issue - priPrinter

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

PDF creating Issue

#1 User is offline   CoMPi 

  • Advanced Member
  • PipPipPip
  • Group: Senior Members
  • Posts: 208
  • Joined: 05-April 13

Posted 07 February 2014 - 01:10 PM

Recently I was playing a bit with PDF Tools from priPrinter Pro (64 Bit) v6.0.3.2255. Trying to create PDF from a simple test file containing lines and filled shapes (PDF_Test.priPrinter) I was surprised by the result (PDF_Test - priPrinter Pro). Printing the test file into the PDFCreator virtual printer caused no problem. In such case the resulting PDF file was correct (PDF_Test - PDFCreator). I suppose the problem is connected with custom pens which I use in the test file.

Piotr

Attached File(s)


Piotr
0

#2 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 07 February 2014 - 02:20 PM

Hi, I see.

Should be related to pens. Which software did you use for creating this ?
Hope to fix this ASAP.

Thanks,
0

#3 User is offline   CoMPi 

  • Advanced Member
  • PipPipPip
  • Group: Senior Members
  • Posts: 208
  • Joined: 05-April 13

Posted 07 February 2014 - 02:24 PM

The soft is developed by me.
Piotr
0

#4 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 07 February 2014 - 08:18 PM

View PostCoMPi, on 07 February 2014 - 02:24 PM, said:

The soft is developed by me.

Great!

Again, thank you for the sample!
Initially I thought that something is completely wrong with pens. But later I found that dashes are used in different places and somehow affect these circles...
So, problem was in caching dash pattern.

Please download and try new beta.

Also I see a problem with Line Join style - this one will be fixed tomorrow.

This post has been edited by Alex: 07 February 2014 - 08:44 PM

0

#5 User is offline   CoMPi 

  • Advanced Member
  • PipPipPip
  • Group: Senior Members
  • Posts: 208
  • Joined: 05-April 13

Posted 07 February 2014 - 09:28 PM

Everything looks much better except the line segment joins. Creating geometric pens I set the PS_JOIN_ROUND flag. I think the resulting PDF file contains pens which are created with the PS_JOIN_MITER flag instead. The differences are well visible in attached files.

You were faster :)

Attached File(s)


This post has been edited by CoMPi: 07 February 2014 - 10:33 PM

Piotr
0

#6 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 08 February 2014 - 12:21 PM

Please download and try latest beta.
0

#7 User is offline   CoMPi 

  • Advanced Member
  • PipPipPip
  • Group: Senior Members
  • Posts: 208
  • Joined: 05-April 13

Posted 08 February 2014 - 10:18 PM

Almost. First problem, a logo. The logo should be hidden as it is in the test file. Unfortunately it is visible in the upper left corner of the drawing Posted Image
The next problem is related to caching. In some places the digit 1 is rendered with invalid line join style, same as it was before.
See the picture where I marked red these problems.

Piotr

Attached File(s)


Piotr
0

#8 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 09 February 2014 - 01:19 PM

Please try again, however I can't repeat that problem with "line join setting". Hope it will disappear, if not - will dig further.
0

#9 User is offline   CoMPi 

  • Advanced Member
  • PipPipPip
  • Group: Senior Members
  • Posts: 208
  • Joined: 05-April 13

Posted 09 February 2014 - 08:39 PM

I confirm, the problem does not occured anymore Previously I have installed priPrinter Pro v6.0.3.2257.

Great job :)

Piotr
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users