priPrinter: Disable preview window and run script - priPrinter

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Disable preview window and run script

#1 User is offline   sjx 

  • Member
  • PipPip
  • Group: Senior Members
  • Posts: 21
  • Joined: 17-November 11

Posted 02 August 2013 - 04:30 AM

In the latest PP you mentioned "Now it is possible do not activate priPrinter window after receiving new print job."

I found 3 related settings

file > print setup>advanced>preview pane: never show
file > options>advanced tab > activate preview window
windows start menu > settings > printers> priprinter > printing preference > settings > do not show preview

Could you explain the differences among these 3 preview settings?

I just want the printing job to be saved as a .priPrinter file without opening any PP window. I don't want the printing job to be sent to the physical printer either. I also have a PP script running to rename the new generated .priPrinter file for each printing job by specifying the script name in windows start menu > settings > printers> priprinter > printing preference > settings > run script.

I have set the above 3 settings to "never show preview" but each time I print a document to PP, there is a splash window. It's not a big deal, but is there a way to disable the splash?


in windows 8
rename script works but a new PP process is started in the background for each printing job (use task manager to see). So 5 printing jobs generates 5 PP processes.

in windows XP
rename script does not work and there is no PP process in task manager
0

#2 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 02 August 2013 - 06:54 AM

#file > print setup>advanced>preview pane: never show
This one is related to printing from priPrinter.

#file > options>advanced tab > activate preview window
This is about moving priPrinter window on top of rest windows.

#windows start menu > settings > printers> priprinter > printing preference > settings > do not show preview
This is what you need - do not show preview at all.

I will check why preview window is displaying. I thought, it should be completely hidden... ok, have to double check.
Please attach your script, will check it on Win8 and XP.
0

#3 User is offline   sjx 

  • Member
  • PipPip
  • Group: Senior Members
  • Posts: 21
  • Joined: 17-November 11

Posted 02 August 2013 - 04:19 PM

Before we make things more complicated, could you tell me what the settings are if

1. I just want the printing job to be saved as a .priPrinter file without opening any PP window.
2. I don't want the printing job to be sent to the physical printer automatically either.

After I set the "do not show preview" (the 3rd one), the printing job goes directly to the physical printer.






View PostAlex, on 02 August 2013 - 06:54 AM, said:

#file > print setup>advanced>preview pane: never show
This one is related to printing from priPrinter.

#file > options>advanced tab > activate preview window
This is about moving priPrinter window on top of rest windows.

#windows start menu > settings > printers> priprinter > printing preference > settings > do not show preview
This is what you need - do not show preview at all.

I will check why preview window is displaying. I thought, it should be completely hidden... ok, have to double check.
Please attach your script, will check it on Win8 and XP.

0

#4 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 02 August 2013 - 05:11 PM

After quick check of "do not show preview" I can confirm that it does not work as expected, at least not sometimes. I can see extra priPrinter processes :(

Right now, you can do:
1. Uncheck "do not show preview" option.
2. Create small script and select it in [Run Script [V]] combobox. Script may contain only one line:
window.Exit();


After that it will save job, do not print to real printer and perform exit. But there will be splash.
Don't worry, I will ask to check what is wrong with that option and will be back to you. I hope it will be solved in a one or two days...

View Postsjx, on 02 August 2013 - 04:19 PM, said:

Before we make things more complicated, could you tell me what the settings are if

1. I just want the printing job to be saved as a .priPrinter file without opening any PP window.
2. I don't want the printing job to be sent to the physical printer automatically either.

After I set the "do not show preview" (the 3rd one), the printing job goes directly to the physical printer.

0

#5 User is offline   sjx 

  • Member
  • PipPip
  • Group: Senior Members
  • Posts: 21
  • Joined: 17-November 11

Posted 02 August 2013 - 06:45 PM

It looks like the "do not show preview" and "run script" options need a computer reboot to take effect. Is this true? For example, the script still runs after the [Run Script [V]] combobox is cleared and the reset button is pressed.

Which setting in PP controls if the printing job goes to the physical printer directly? It used to be the "do not show preview" option. If it's enabled, the job goes to the physical printer, otherwise, PP is opened.
0

#6 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 02 August 2013 - 07:05 PM

No, this is not true or this is a BUG. Sorry for this.
Probably related to multiple instances - still under investigation.
0

#7 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 03 August 2013 - 04:22 PM

We've made few fixes and now "do not show preview" and "run script" should work fine.
Basically, there was a bug: In case if script is specified, then information about calling from driver side becomes lost. As result script was not running, file was not copied to history folder and more... till running in background.

Now it should be fixed and everything works quite good on my side.
Also there was one more splash in skinned color scheme - it's fixed as well.

update is here: www.priprinter.com/beta.htm

So check [X]do not show preview and select script.

Hope it will work for you as well.

Regarding computer reboot. Applications may keep their own copy of printer settings, so you may need to restart those applications or change options in Print dialog.
0

#8 User is offline   sjx 

  • Member
  • PipPip
  • Group: Senior Members
  • Posts: 21
  • Joined: 17-November 11

Posted 09 August 2013 - 07:15 PM

The problems are not solved in 5.6.1.2073, at least on my computer.

for problem 1 try this

tick "do not show preview", the printing job goes to the real printer directly. what we want is the print job to be saved as a .priprinter file.

and

for problem 2 try this

specify a script name in the combobox, print a job to PP. the script is executed as expected. now clear the combobox or press the reset button, close the printing preference dialog. if you print a job to PP, the script is executed. this is not what we want either.
0

#9 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 09 August 2013 - 07:46 PM

Thank you for checking.
I can confirm second problem with clearing script combobox with help of Reset button. Clearing with backspace works fine. In any case Reset will be fixed, clearing with keys will be double checked.

First problem: Yes, job will go to real printer, unless any script is specified.
If script is present, then everything will be controlled by script and script should print explicitly.

Can you please confirm that script is selected in combobox? May be screenshot of printing preference dialog?
0

#10 User is offline   sjx 

  • Member
  • PipPip
  • Group: Senior Members
  • Posts: 21
  • Joined: 17-November 11

Posted 09 August 2013 - 08:09 PM

tick "do not show preview" and specify a script name test. see the attached jpg
the PP window is still opened


test.psf

local testFilename=window.GetFolder("arc") + "\\file.txt";
local f=File(testFilename,"w");
if(f.ok)
f.Write("test text\r\n","sa");

Attached File(s)

  • Attached File  1.jpg (47.25K)
    Number of downloads: 7

0

#11 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 09 August 2013 - 08:21 PM

Right... Sorry for this
This is a new behavior in this build. In case if script did not close priPrinter, main window will be activated. Goal is to avoid ghosts in task manager.
Just add this line to the end of your script.
window.Exit();

Actually it can be in any place - it is just a flag which will be checked later.
I checked your code with this new line and everything works.

local testFilename=window.GetFolder("arc") + "\\file.txt";
local f=File(testFilename,"w");
if(f.ok)
f.Write("test text\r\n","sa");
window.Exit();

0

#12 User is offline   sjx 

  • Member
  • PipPip
  • Group: Senior Members
  • Posts: 21
  • Joined: 17-November 11

Posted 09 August 2013 - 08:27 PM

Are you saying we don't need to use "window.Exit();" in script explicitly in future release of PP?
0

#13 User is offline   Alex 

  • Administrator
  • Group: Administrators
  • Posts: 238
  • Joined: 28-February 10
  • LocationHungary

Posted 09 August 2013 - 09:18 PM

View Postsjx, on 09 August 2013 - 08:27 PM, said:

Are you saying we don't need to use "window.Exit();" in script explicitly in future release of PP?

window.Exit(); will be required if you want to close priprinter.
The reason is - better to show main window in case of "runtime error" or mistake in script instead of silently dying.
Hope you don't mind.
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users